Faster CPU Miner, double the speed!


#22

Sounds like different averaging algorithms to me. This is quite normal for pool miners. There’s also the issue of how many hashes you find per second vs how many the pool actually uses: usually very different numbers.

@fluffball why does your miner say “I run faster as root?”


#23

Dual Xeon E5-2658’s (8c 2.1Ghz each)
DDR3 1866 interleaved 4 channels per socket

fluffyminer , best result not using hyperthreading (so 16 threads)
560H/s

2 Instances using Numactl to lock 8 threads to each die using it’s local ram only,
290H/s so slightly faster 580H/s

Anyone tried turning hyperthreading off in BIOS?


#24

#I hope everyone realizes that Intel’s Generation and computing power system is stupid.
#The iX does not mean much. It’s iX-YZ+some other 2 numbers that count. Xeon processors are your best bet to mine raw dog and in pool, but a higher-core Xeon (I’m talking about xeon e7-2699 v4, 24 cores, server-grade chip) cost upwards of $5,000.

i5-6600 @ 3.31 Ghz, 4 cores
16GB DDR4 2133
Adolfnode H/s (raw dog, 3 cores dedicated) - MIN/MAX = 50.7368 MIN / 108.1579 MAX
fluffyminer H/s (3 cores dedicated) - MIN/MAX = 100.54 MIN / 120.5983 MAX

Zapto gives me a hash of like 33 or 40/s, but whatever.


#25

mfw Xeon E5-2658
mfw he has 2 of them


#26

Dat L2 cache :slight_smile:

yfw i have another single 2658 on a mini itx i3/5/7 board getting 280

Probably just leave that one running, now our shekelgrubbing gigaminer has gone, it’s nice and quiet


#27

That’s just leftover code from wolf or someone, it doesn’t seem to go any faster as root. I’ll remove that notice.


#28

it doesn’t seem to go any faster as root

When run as root, it sets its nice priority to -14 (on my computer). I found this out when I accidentally ran it as root in my startup scripts, and it slowed down everything. I suggest you just let users set the priority by themselves.


#29

I’ll just remove the run as root notice and release it under the fuhrerprocess, if someone sees this as a big enough problem they’ll send a pull request but I think its fine (just run as a normal user).


#30

I have quite a few CPUs running mining Monero, and it is better to run them on only 3 threads. The reason I gathered was that the way the cryptonight algorithm works, the thread number depends on your L3 cache size. If your CPU has 8MB of L3 cache (i7 CPUs), use 4 threads. For 6MB, 3, and so on.
At least, according to Claymores miner.


#31

i’m trying to run this fluffyminer on windows when i click start_mining it opens and closes again instantly before i can read anything. i set my wallet address and number of threads, do i need to configure anything else? on win8 64bit, was running cpuminer fine.


#32

You’re probably using a mein original wallet address, but I just moved my pool over to the neugrunding (shitminer tears) fork so you need a neugrundung address.

How did you generate your wallet address?

Edit: I didn’t open the ports properly on my pool after the update - if that’s what was causing it it will probably work now.


#33

yes it’s a new address, generated with wallet from new release. working on ccminer now. maybe my laptop isn’t compatible ?
intel celeron CPU n2840 @ 2.16ghz 64bit win8.1
couldn’t get the new adolfnode working either. maybe a sign to get a new pc


#34

OK when i launch CPUminer it says CPU Supports AES-NI: No and i just re-read the download instructions and saw that was required i think. problem solved sorry


#35

Oh ok, that’s why. Adolfnode should still work though. Also there is a non-AESNI miner for my pool which you can try, cpuminer by tpruvot. There’s a windows binary for it floating around somewhere, I’ll see if I can find it, otherwise I’ll compile it and post it to the getting started page of the pool.


#36

yes im mining on cpuminer atm


#37

did you compile for OSX?
can you share?


#38

You’re in luck. @brbdanzig just got the node working on OSX and it mines as fast as this miner on CPU. This means you can also use the wallet properly on mac now too which is pretty cool.

Have a look at this: https://github.com/Adolfcoin/adolfcore-Neugrundung/pull/12

Essentially:

Open a terminal and run
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
(copy and paste that whole line exactly including the quotes)

Then type brew install libevent into the terminal to install libevent

Then download the file from https://github.com/Adolfcoin/adolfcore-Neugrundung/files/1133949/ac-neugrundung.zip

Then you should pretty much be able to do what it says for Windows here: https://github.com/Adolfcoin/adolfcore-Neugrundung/releases you’ll probably need to do that thing in OSX where you go to system preferences => security and privacy and allow the executable because it isn’t signed.

When you run into problems just create a new forum thread in the technical help category and someone will help you :slight_smile:

Things should start getting easier for mac users with the next release since more of us are using it on OSX now.

PS: I’ll have a look at fluffball’s miner and see if I can compile it statically for OSX, if I get it working I’ll ping you here.


#39

Are you saying tpruvot’s cpuminer with the CryptoNight method is more efficient than raw dogging it with adolfnode?

My Xeon X3360 without AES instructions, @ 2.83 GHz has 2 x 6 MiB L2 cache and currently is averaging ~91 hashes/sec.


#40

I looked into this before and the miner included with the node is FAST, it doesnt use AES but for a non-AES cpu none of the pool miners can beat it (on my hardware anyway). There’s also pool fee and pool lag to take into consideration. Raw dog is the best if you arent using GPU or AES.


#41

Celeron B830 @1.8GHz
adolf-node: 12H/s
xmr-stark / adolfpool.org: 9.5H/s