File missing error for GUI wallet - Vergeltung fork, Windows 8.1


#1

After launching the GUI, I receive this error saying that api-ms-win-core-heap-l2-1-0.dll is missing from my system. A Microsoft Support post with a similar issue talks about the Universal C Runtime, so I try installing an update. The GUI still gives the same error. The adolfnode and wallet CLI work though.


#2

i am not sure maybe it has something to do with windows firewall or whatever blocking it?


#3

Seems unlikely that a missing file error would be caused by windows firewall.

The command-line gives a prompt for firewall permission as it should. Tried re-downloading the fork but the error still pops up.


#4

Try copying that file to the adolfcoin directory and see if that works


#5

Turns out I made a mistake in my first attempt to solve this issue. See my edited post.

Now, after trying some tricks (renaming similar files) I receive a new error:

The procedure entry point LocalAlloc could not located in the dynamic link library

It goes on to refer to d3dcompiler_47.dll in the adolfcoin directory


#6

You should probably just use Windows 10, it works perfectly for me in there


#7

Hmm… I’m not too fond of Windows 10’s intensive data collection…

I suppose I’ll try a VM.


#8

If you use a VM just use Ubuntu and build it from source, it’s painful but also rewarding


#9

I compiled the Windows binaries on WIndows 10, to be completely honest I wouldn’t trust Windows 8 any more than Windows 10, precautions are not unrequired in both cases. You can probably follow the Windows build instructions and compile your own binary, it should work on Windows 8 and shouldn’t be too difficult.


#10

I see. That makes sense.

I’ll try compiling from source.


#11

i use windows 8. i think i had problems launching the last update (neugrundung) on this PC but vergeltung installed and runs fine for me. i pool mine with a separate windows miner though so i don’t have a need for it, but i did use it to generate my wallet address etc

do you have like visual studio libraries and stuff installed? not sure if it’s necessary but could help. maybe C++ libraries or whatever the other windows libraries there are

https://go.microsoft.com/fwlink/?LinkId=746572


#12

Windows 10 Universal CRT for early Windoze is here:
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows


#13

A friend had the same issue with iTunes on Windows 7, that update (which I found googling the iTunes error) solved it.
Not before reinstalling iTunes a couple of times, the Visual C runtime a couple of times and running sfc /scannow, of course.