Wallet is not compatible with latest boost libs on linux


#1

Boost libs 1.66.0 changed their API enough to make the wallet incompatible. Monero’s wallet is up to date, though.
This can be solved on arch by installing boost-65-compat to restore 1.65.1 libs alongside the latest version, but this only works if you already have the wallet compiled with the 1.65.1 headers. These headers are no longer available (downgrade would cause conflicts).
Another work around would be configuring the build to use a custom location for 1.65.1 headers but I don’t know how to do that.

Any help with backward compatibility would be appreciated, otherwise this is just a bug report.