Wallet recovery from seed


#1

I’ve read over the wiki brief on GitHub here and it notes that:
You’ll then see a list of 25 words. Write these down, they can be used to recover your wallet if you ever lose it.
…however it does not describe the command used to restore a wallet using the recovery string.

Is such functionality implemented into the wallet at this stage?


Importing private key from wallet generator
#2

You can start the wallet program with the option --restore-deterministic-wallet

Then it will ask you for a file name to store it as and a password (all like normal), but the final option will be to put in the 25 words.

Then when it’s open type refresh and it should sync (you need the daemon running in another window when you do that).


#3

Thanks meko!

Just saw the same advice on SO for the monero wallet. I think what threw me was it appeared to be just going through the motions so I quit wallet creation thinking it was simply going to create another fresh one. That seemingly hidden final s̶o̶l̶u̶t̶i̶o̶n̶ option was tripping me up.


#4

This is one of the things that could be better documented…

It shouldn’t be “that hard” to find, but it’s not that easy either…


#5

Yeah. I did consult the wiki at GitHub here after seeing a note in Issues that you made @uncle8 on the zero version here however the Wiki in it’s current form is missing “wallet recreation from seed” steps.

Is the Wiki a shared doc that can be edited by anyone who joins the org at GitHub?


#6

@acf yes, the idea at least is that anyone can edit them. But I think there was some kind of problem with it being a ‘wiki’ on github and it has to be copied/pasted over to a normal repository.

Are you familiar with github?


#7

Yes, what @meko said, basically. Anyone can contribute, it just needs to be “accepted” by a maintainer, but it is no problem usually, and especially not in this case. Someone just has to do it…

It would make sense to have it in the code of wallet too, but that’s for later, and fuhrer is working on an improved graphical version now, so I’d see how that turns out first…

:slight_smile:


#8

@meko yes, codewise – not too big on markdown but there are js markdown editors online that seem to do the job.

@uncle8 Agreed. I might create a panzer division account at GitHub tomorrow if someone doesn’t get in before me :wink:


#9

That would be a very good idea.

You could just use that same repository and send a pull request with all the docs, putting them in root of the repo. Then they can easily by edited using normal fork+pull with the fuhrerprocess. I’m pretty sure the problem was that github wikis can only be edited directly and you cant use pull requests, @meinfuhrer is that right?


#10

As @meko suggested, the problem is simply that for some very silly reason Github doesn’t allow pull requests on Wikis or any form of editing which encompasses checks and balances. I’ve simply been too busy to do much regarding documentation - moving it somewhere compatible with the Führerprocess (i.e. .MD files in a normal repo) or adding much needed items such as --restore-deterministic-wallet, so someone stepping in to do that would be greatly appreciated :slightly_smiling_face:

I haven’t thought about the best arrangement for documentation but there’s definitely no harm in having it all in one place at least for now. In future some of it will probably be specific to individual forks (though nothing in the Wiki so far falls under that description), but other things like API documentation should usually be uniform across all forks anyway because we do not break userspace! (this is not an endorsement of totalitarian regimes).

There are also some relevant items in the issue tracker that could be copied over from adolfcore-zero to Neugrundung.


#11

What exactly do you mean by “start the wallet program”? I don’t use the graphic interface (exe doesn’t start for some reason), only CLI, but it doesn’t recognize that input line.


#12

I assume you are using Windows.
open a cmd prompt
drag the cli exe
Type an space
after that, write* “–restore-deterministic-wallet” with or without the quotes.
press enter

*(or copy-paste, you have to right-click and click “Paste” on the pop-up menu, since in cmd, Ctrl+V doesn’t work)


#13

You can open a command prompt by pressing WinKey+R, typing “cmd” or “cmd.exe” with or without quotes and pressing enter or clicking “Accept”.


#14

Thank you, the reset worked, and yes, like the posters above said, this workaround should be included in the official documentation. Like the poster in another thread asked, how can I verify now that the mining process indeed works? Sometimes I got my station mining for days in a row, seeing the “block solved” message from time to time, but this seems to refer to all miners in general. Is there a specific message if your local client solved a block?


#15

Are you mining solo (using the official Adolfcoin client) or in a pool?
If mining solo, you can see the blocks you mined in the “History” tab of the GUI, and you will get a message “[Miner n] INFO GLOBAL […] Found block for difficulty: […]” in the command line window.

In order to TURN ON mining in the GUI, go to the “Advanced” tab, in the submenu choose “Mining”, set the number of “CPU threads” to up to as many cores as your processor has, then click “Start mining”.

If you are mining in a pool, I don’t know exactly what you should see, since I haven’t, but I would expect the pool’s website to give you some info, and read the documentation of your mining software to see what messages you should be getting.

You should mine solo on computers, by the way. Blocks are mined often enough even with slow hash rates, you don’t pay any commission, it’s more efficient, and there is less centralization, which is a good thing.


#16

Thank you for your reply. Yes, I’m solo mining on an old rig of mine, but without the GUI client - when I try to start it, it just returns to desktop. Some sort of bug? Does anyone else got this one? So only CLI at the moment for me, and it seems to work now. Current uptime is about 4d, with about 7.58 coins mined, which also appear in the wallet. I will learn step-by-step how everything works.


#17

Yeah, the GUI not starting is weird. First thing I would try is downloading and extracting it again, just to rule out any missing or corrupted files. Is your system up to date?


#18

Alright, I will try this.

What exactly do you mean by this?


#19

Do you have all system and runtime updates installed? If not, I recommend using wsus offline to make sure it is.

http://www.wsusoffline.net/


#20

Also make sure your graphic drivers are up to date, and try disabling Aero if it is enabled.